Torque converter shudder - Page 2
Page 2 of 7 FirstFirst 1234 ... LastLast
Results 16 to 30 of 99
Like Tree50Likes

Thread: Torque converter shudder

  1. #16
    Senior Member
    Gold Supporting Member
    elegant's Avatar
    Join Date
    May 2013
    Location
    Pacific Northwest
    Mileage
    17,250
    Posts
    18,663
    Member #
    496
    Liked
    19642 times
    This is one interesting TSB on driveline vibration, that per this TSB, re the '15-17 automatics that are experiencing this could be caused by transmission fluid issues. Wonder how many torque tubes and more have been erroneously replaced, prior to this brand new TSB being identified.
    Vigilance247 likes this.
    John

    Fortunate owner of "WRP SPD," our Z06! [7M, stage 2+ coupe]. List of mods here:
    Hidden Content

    Lifetime & Contributing Member of the National Corvette Museum!

  2. #17
    Super Moderator
    Gold Supporting Member
    jsvette's Avatar
    Join Date
    Mar 2013
    Location
    Vegas
    Mileage
    19k+
    Posts
    14,629
    Member #
    313
    Liked
    10494 times
    Quote Originally Posted by elegant View Post
    This is one interesting TSB on driveline vibration, that per this TSB, re the '15-17 automatics that are experiencing this could be caused by transmission fluid issues. Wonder how many torque tubes and more have been erroneously replaced, prior to this brand new TSB being identified.
    I wondered the same thing John.
    aka Jeff
    'RedHot' Prod.Wk 7 Oct '13 Museum Del. 29 Oct '13
    Torch Red, 2LT Adrenaline Red, AutoTrans., Nav., Perf. Exhaust, Transparent panel, Red Brembos, CQuartz Finest
    Contributing Member of the National Corvette Museum

  3. #18
    Junior Member ken1017's Avatar
    Join Date
    Nov 2014
    Location
    United States
    Posts
    21
    Member #
    4897
    Liked
    6 times

    Transmission shudder and more

    Hello all, guess what? I have the same issue and more. First the transmission, always had shifting issues, complained, nothing done. It would not downshift to the correct lower gear when approaching a corner or a stop sign. The when you accelerate, engine speeds up, then shifts down resulting in a good jolt. Now I have the shudder issues, almost all the time at speeds 30 and higher. Very disturbing on smooth roads, entire car vibrates, alarmingly. No check engine light ever came on but OnStar recently sent a message 'immediate attention' regarding engine/transmission. Took to the dealer where I purchased, is still sitting there waiting for when they can get to it. Agree, I now will have a repaired vehicle. A wrecked body or serious mechanical issue, what's the diff, no longer like new. And if that's not enough, gas gauge not working properly, levels constantly change, sometimes can be full and it shows empty. Even with 4 error codes, dealer did not repair, claimed GM would not pay, guessing because it was 'kinda' working. What good are error codes if they are ignored. Am not the only one with this issue. Disappointed in my dealer who claim 'we want to earn your business,' well, they are not trying at all. This (and previous) Corvettes are all special to me and taken care of, hurts to see it sitting outside for days getting filthy dirty. Am sure they will drive it in the rain too. IF I get another Vette, Maxie Price sounds like the place to go. Disappointed on how I am being treated, what good is a warranty anyway. Great way to lose a loyal customer.
    Attached Images Attached Images  

  4. Remove Advertisements
    StingrayForums.com
    Advertisements
     

  5. #19
    Super Moderator
    Gold Supporting Member
    jsvette's Avatar
    Join Date
    Mar 2013
    Location
    Vegas
    Mileage
    19k+
    Posts
    14,629
    Member #
    313
    Liked
    10494 times
    Ken1017, very unfortunate to read your continued problems with your 2015 C7. Your first post back in January 2015 was so positive "First Vette 1953 (my Dad's); my 1st: 1963 FI coupe; current 2015 C7 Z51; I am 73 y/o, will always have a Vette; keeps the juices flowing!!!" and then apparently nothing but a string of unresolved issues. I strongly suggest you send a PM with your VIN, a description of the issues and which dealer you have been dealing with to our dedicated Chevrolet Customer Care team at "ChevroletCustomerCare" to ask for their assistance on your behalf.
    aka Jeff
    'RedHot' Prod.Wk 7 Oct '13 Museum Del. 29 Oct '13
    Torch Red, 2LT Adrenaline Red, AutoTrans., Nav., Perf. Exhaust, Transparent panel, Red Brembos, CQuartz Finest
    Contributing Member of the National Corvette Museum

  6. #20
    Junior Member ken1017's Avatar
    Join Date
    Nov 2014
    Location
    United States
    Posts
    21
    Member #
    4897
    Liked
    6 times
    Thanks for your thoughts and feelings, my cars are always in pristine shape, engine too. Now to have all the guts ripped out (eventually) is heartbreaking. Will see what they say before I ask for help.

  7. #21
    Senior Member rmorin49's Avatar
    Join Date
    Mar 2015
    Location
    Hagerstown MD United States
    Mileage
    16000
    Posts
    925
    Member #
    5919
    Liked
    871 times
    You guys need a new torque converter. My dealer had never replaced one so my car was in the shop for over 30 days as they waited for "guidance" and parts. I also needed a new fuel pump so they had to completely disassemble the rear of the car including the torque tube, rear axle and transmission. It was all put back together and now it runs much better. Try to find a dealer that has replaced a torque converter. There is a TSB out on this issue. Good luck.
    Hidden Content

    COL(Ret), US Army
    Hagerstown MD
    2016 Stingray Coupe-My First Corvette
    LBT/Grey/2LT/A8/NavPDR/Body Color Vents/Performance Exhaust
    Continental DWS06 Tires
    Mason Dixon Corvette Club

  8. #22
    Junior Member ken1017's Avatar
    Join Date
    Nov 2014
    Location
    United States
    Posts
    21
    Member #
    4897
    Liked
    6 times

    sudder issue got worse

    Follow up to previous article: It's sitting apart at the dealer waiting for parts or when they can get to it. Not much info from the dealer other than the tranny might need to be flushed several times, over a period of time, to remove contaminants. I am concluding there are worn or damaged parts, so am reluctant to even drive any distance for fear of being stuck somewhere. BTW, car is still under warranty. At least this time they are looking into the issue, not just reflashing a module and sending me on my way only to return with the same issue or more. It's a 2015 Z51, but what good is a hi tech masterpiece that can't be serviced. This might be my last Corvette, first was a '63 split window, sebring silver FI
    Attached Images Attached Images  

  9. #23
    Junior Member BabyRay2015's Avatar
    Join Date
    Mar 2017
    Location
    Edmonton Ab, Canada
    Mileage
    46000 kms
    Posts
    22
    Member #
    18369
    Liked
    171 times
    I've been having these issues as well.
    Torque converter has been changed. 3rd gear bump is still there at about 2200-2500 RPM. They flushed out the Tranny 3 times process. Bump is still there. BUT.......... soon after ( approx. 1000km) NOW I get the feeling of going over rumble strips at 1800-2000 RPM. On any gear and on manual or auto mode. Whether you are accelerating or not. Now they are about to change the Torque converter tube. Parts on order. I really hope this works. It also happens in park position. Grrrrrr

    Now!
    They have changed the torque converter tube now. All seems good after driving about 300km testing it out in all modes. Auto or manual. They said the flex plate was fine. They claim there's a bearing on the one end of tube that was getting loose and causing the vibration. I guess we'll see what this one does.
    3rd gear thump (manual mode) still there. I'll see how this goes for now.
    I think I'm ready to write a letter to GM. Cause this ain't just a loose wire problem. This is what drives the car.

  10. #24
    Senior Member cutnout's Avatar
    Join Date
    May 2014
    Location
    Milton, Fl
    Posts
    1,096
    Member #
    3202
    Liked
    788 times
    In the automotive business its always interesting that what worked last year doesn't the following year. Must be an axiom or a genie. Charlie aka cutnout
    2017 convertible W/Z51, 3LT, auto, chrome wheels, magnetic ride control W/PTM, wifi, remote start, Black Rose, Kalahari/ Black top --Found at a dealer (forum supporter) delivered April 10, 8 miles on the odometer. Charlie

  11. #25
    Member ronjohn11's Avatar
    Join Date
    Jul 2015
    Location
    Orlando, FL.
    Posts
    60
    Member #
    7049
    Liked
    21 times
    Well, I've been bitten by the torque converter bug. Absolutely terrible condition that feels like my '16 Stingray is going to sling me out of the car any minute. I've taken it to the dealer who flushed the tranny 3 times but it didn't fix a thing. Now I have to wait a week for the parts and who knows how long it will take to actually fix the problem. It looks like this issue has been going on since day one. Isn't it time for GM to issue a recall? Please let me know if anyone had this condition and it was fixed or any updates to this issue. Thanks.
    Last edited by elegant; 08-09-2017 at 03:08 PM.
    A8, 2016 Laguna Blue with matching roof, 2LT, Nav and PDR, Red Calipers, Red Wheel Bands, Z51 Rear Air Deflector, Grey Interior, Splash guards (front and rear).

  12. #26
    Senior Member rdslon01's Avatar
    Join Date
    Dec 2013
    Location
    Charlotte Metro Area, North Carolina
    Mileage
    3559 as of September 4, 2016.
    Posts
    10,137
    Member #
    1658
    Liked
    6030 times
    Quote Originally Posted by ronjohn11 View Post
    Well, I've been bitten by the torque converter bug. Absolutely terrible condition that feels like my '16 Stingray is going to sling me out of the car any minute. I've taken it to the dealer who flushed the tranny 3 times but it didn't fix a thing. Now I have to wait a week for the parts and who knows how long it will take to actually fix the problem. It looks like this issue has been going on since day one. Isn't it time for GM to issue a recall? Please let me know if anyone had this condition and it was fixed or any updates to this issue. Thanks.
    Oh, that is really sad news. How many miles do you have on it?
    Last edited by elegant; 08-09-2017 at 03:09 PM. Reason: Edited quoted section only.
    Rodney and C.A.R.O.L.I.N.E. (Candy Apple Red, Outrageously Lovely, Incredibly Nimble Entertainment)

    C.A.R.O.L.I.N.E. is a 2016 Long Beach Red, 3LZ, Stage 1, Z06 Coupe with an Automatic 8-speed transmission, the Spice Red Design Package, Competition Seats, a Carbon Flash Hood Stinger, and a Body-Colored Dual Roof Package. She has SunTek paint protective film installed on every painted surface other than on some of the vents' and grille's slats, G3 Carbon's "G3-O7" side skirts, GM StingRay Red Tail Lights, GM Rear Splash Guards from Trunk Monkey, ACS Composite Enhanced Front Wheel Mudflaps from West Coast Corvette, and her mufflers painted with POR15 Aluminum high temperature paint.

  13. #27
    Member ronjohn11's Avatar
    Join Date
    Jul 2015
    Location
    Orlando, FL.
    Posts
    60
    Member #
    7049
    Liked
    21 times
    The TC issue in this thread has reared its ugly head in my 2016 C7, A8 with a little over 7,000 miles. Took it in at 7,571 mile. Dealer flushed the transmission mission 3 times but it did not fix the issue. Did GM fix the problem "Tuner Boost"? No update on this thread since 2014. Is GM listening? Need suggestions on dealing with this issue.
    A8, 2016 Laguna Blue with matching roof, 2LT, Nav and PDR, Red Calipers, Red Wheel Bands, Z51 Rear Air Deflector, Grey Interior, Splash guards (front and rear).

  14. #28
    Senior Member rdslon01's Avatar
    Join Date
    Dec 2013
    Location
    Charlotte Metro Area, North Carolina
    Mileage
    3559 as of September 4, 2016.
    Posts
    10,137
    Member #
    1658
    Liked
    6030 times
    Quote Originally Posted by ronjohn11 View Post
    The TC issue in this thread has reared its ugly head in my 2016 C7, A8 with a little over 7,000 miles. Took it in at 7,571 mile. Dealer flushed the transmission mission 3 times but it did not fix the issue. Did GM fix the problem "Tuner Boost"? No update on this thread since 2014. Is GM listening? Need suggestions on dealing with this issue.
    Document everything. Make sure you get this resolved before you run out of warranty. Pressure the situation, and let GM know, in writing, that you need help. Work for a solution with them, but, like I said, document everything just in case it does not get fixed. You want to make sure you have all of your information organized if you ever have to go the buy-back (or lemon law) route. Hopefully GM corporate will get involved and get it totally fixed so it will never come to that. I am sure you know of the saying "Hope for the best, but prepare for the worst."
    Rodney and C.A.R.O.L.I.N.E. (Candy Apple Red, Outrageously Lovely, Incredibly Nimble Entertainment)

    C.A.R.O.L.I.N.E. is a 2016 Long Beach Red, 3LZ, Stage 1, Z06 Coupe with an Automatic 8-speed transmission, the Spice Red Design Package, Competition Seats, a Carbon Flash Hood Stinger, and a Body-Colored Dual Roof Package. She has SunTek paint protective film installed on every painted surface other than on some of the vents' and grille's slats, G3 Carbon's "G3-O7" side skirts, GM StingRay Red Tail Lights, GM Rear Splash Guards from Trunk Monkey, ACS Composite Enhanced Front Wheel Mudflaps from West Coast Corvette, and her mufflers painted with POR15 Aluminum high temperature paint.

  15. #29
    Senior Member
    Gold Supporting Member
    elegant's Avatar
    Join Date
    May 2013
    Location
    Pacific Northwest
    Mileage
    17,250
    Posts
    18,663
    Member #
    496
    Liked
    19642 times
    I am sorry your problems are occurring. I would return to your dealer, gently explain that what they did last time has not worked, and they need to fix this, to succeed this time.

    In your "hip pocket," if they do not, I would next recommend you proceed to exactly follow the procedures outlined in your Owners Manual, sections 13.1-13.3.

    We all hope that this is not necessary, that they fix it right this next time.
    NPRL likes this.
    John

    Fortunate owner of "WRP SPD," our Z06! [7M, stage 2+ coupe]. List of mods here:
    Hidden Content

    Lifetime & Contributing Member of the National Corvette Museum!

  16. #30
    Member vettstings's Avatar
    Join Date
    Dec 2014
    Location
    Palm Harbor, Florida
    Mileage
    433
    Posts
    30
    Member #
    5160
    Liked
    17 times
    Ronjon, I had a torque converter problem on my 2015 Stingray A8, with 3400 miles. I had the familiar symptoms, bouncing tach, running over rumble strips feeling, etc etc. The dealer service I purchased it from said, after a test drive, "that's just the AFM working". I could immediately tell they were unable or unwilling to solve this issue. I called Stingray Chevrolet, a 50 mile drive from me, took it there and their service manager barely got out of the parking lot and returned stating that I needed a torque converter. They repaired the car in less than a week I have had zero problems since. They sell about one Corvette a day so they do a lot of service work. My repair happened in May of this year. I wish you luck repairing your car.
    NPRL likes this.

Page 2 of 7 FirstFirst 1234 ... LastLast

Sponsored Links

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •  

Search tags for this page

2014 corvette torque converter problems
,
2014 stingray torque converter problems
,
c7 corvette tach fluctuate
,
c7 corvette torque converter issues
,

c7 corvette torque converter problem

,

c7 corvette torque converter problems

,
c7 torque converter issues
,
c7 torque converter location
,
c7 z06 converter issue
,

corvette c7 torque converter problems

Click on a term to search for related topics.
 

SEO by vBSEO ©2011, Crawlability, Inc.