Stingray Corvette Forum banner

1 - 20 of 37 Posts

·
Registered
2014 Premier Edition
Joined
·
91 Posts
Discussion Starter #1
Ok, the specifics first:
SW Florida - so cold should be no issue
2014 Premier Edition Z51 M7
3300 Miles (NO that's NOT a typo!)
I bought it at 2950

Issue: if driving "normally" and not "on it" there is what seems to be a slight grinding when going 1-2, and maybe a LITTLE once in a while from 2-3.

I've read all of the threads I could find on it and I think this seems like a reasonable plan of attack; Opinions/suggestions?

1) Drain tranny fluid and replace with Dextron 6
2) If #1 doesn't resolve then do TSB Procedure (New TSB/Recalls)
3) If both of those don't do it, replace with MGW Shifter
4) If none of the above work.... start day drinking. ;)

?
277835
 

·
Registered
Joined
·
404 Posts
I agree with the sequence of your plan, anyway! It does sound like an adjustment is needed, as it should not be doing that at all.

By all accounts, you cannot go wrong with the MGW shifter upgrade. I have not done this yet; maybe they will drop their prices now that the last M7 has been already built.
 

·
Registered
2014 Premier Edition
Joined
·
91 Posts
Discussion Starter #3
I actually stopped by my mechanics place this morning and discussed it with him. He said it didn't sound serious to him. He said he didn't agree with changing the tranny fluid. He said with tranny fluid, it's how many contaminates it can hold, not it's age and with 3800 he said in his opinion it wouldn't help but.... he didn't have time to actually drive the car either as he was up to his armpits in a motor. lol I'm going to stop back, when the system is "cold" and when he has time and he's going to drive it and see what he thinks and we'll go from there. It may well be I'm just being picky and it's the beefed up syncro gears between 1-2, 2-3.

As for the shifter, I've read a ton of reviews on it. Some love it and have zero problems/issues with it and others are totally opposite.... so I'm on the fence about that.

One thing I HAVE to do is to get the blackout side marker replacements for those red and yellow thangs..... ;)
 

·
Registered
Joined
·
404 Posts
I'm trying to remember, but for sure my shifter got smoother after the break in period, and it seems like it was in the 3k to 5k range.

My '17 GS is white with a red stinger stripe and red stripes on the black wheels. The whole color theme, inside and out, is white/black/red, except for the front side marker lights. There are body-color replacements out there, but I the reviews I read indicated fit problems and customer service problems for those who went with them.

I wonder if those with negative reviews of the shift kit installed them themselves?
 

·
Registered
2014 Premier Edition
Joined
·
91 Posts
Discussion Starter #5
Ok, thanks. Maybe I'm still in the "break in" period with 3800 on the clock.

As for the side markers, I'd have my mechanic do it (I'm lazy) ;) The yellow and red look dumb on mine, at least I think so, I think black would look much better... you?

277841
 

·
Registered
Joined
·
404 Posts
Well, I've had since 1964 to get used to the look of side marker lights. I can see where your car might look better if those lenses were toned down. I would still prefer a body color look, though.
 

·
Registered
2014 Premier Edition
Joined
·
91 Posts
Discussion Starter #7
Thanks. All opinions welcome. :D I'm not new to the neighborhood ('84... which I loved btw) but not as early as you. :)

I think the black markers would be a drastic improvement over what's there, but that's just me....
 

·
Registered
Joined
·
404 Posts
I was thinking of 1968, when side marker lights first came out, and they all had a "tacked on" look to them, regardless of the manufacturer. 1967 cars just looked better. Harder to see at night, but they looked better.
 

·
Registered
2014 Premier Edition
Joined
·
91 Posts
Discussion Starter #9
The new ones are only "dark" when you don't have the lights on. Turn the lights on and they turn yellow and red respectively. Which I actually like.
 

·
Registered
Joined
·
10,328 Posts
Thanks. All opinions welcome. :D I'm not new to the neighborhood ('84... which I loved btw) but not as early as you. :)

I think the black markers would be a drastic improvement over what's there, but that's just me....
For what it's worth, I personally think your car looks great as-is.
 

·
Registered
2014 Premier Edition
Joined
·
91 Posts
Discussion Starter #11
For what it's worth, I personally think your car looks great as-is.
Well, thanks! I kinda like it too! ;) Just think it'd look more coherent with dark side markers given all of the black carbon fiber everywhere else.
 

·
Registered
Joined
·
404 Posts
I think you are right, stevec, you should go for it with the blackout lenses. It should look sharp on your car.

As for the shifter, I did say mine got better, but I never had the issue you are seeing with mechanical noises. It really sounds like an adjustment would help.
 

·
Registered
2014 Premier Edition
Joined
·
91 Posts
Discussion Starter #13
Thanks, the car only has 3800 miles on it too so I have to factor that in. I read somewhere someone said this can happen until after 5k. I'm still going to have my mechanic drive it and see what he thinks. I'm probaly just being my normal anal self. ;) At some point I will probably spring for the markers
 

·
Registered
Joined
·
654 Posts
Mine NEVER does that after it's warmed up a bit. (and 80F in Florida is cold for a transmission... Think first drive of the day) In fact, after about a 1/2 mile it doesn't do it and never has. Not before the MGW nor after. (4k miles before, 20K after) If it's just a slight grind, it may your shifting technique. When it the first drive, it like a slightly more deliberate shift into second.

Once warm, I can do anything to it and never feel a thing.
 

·
Registered
2014 Premier Edition
Joined
·
91 Posts
Discussion Starter #15
Doubt seriously that it's my shifting. Been driving standards since 1970. Gonna take it to Pat "cold" and let him drive it. It may just be the heaver syncros of the Z51 1st-2nd
 

·
Super Moderator
Joined
·
3,352 Posts
Doubt seriously that it's my shifting. Been driving standards since 1970. Gonna take it to Pat "cold" and let him drive it. It may just be the heaver syncros of the Z51 1st-2nd
Not debating your shifting skills, but have you tried shifting at a higher RPM?
 

·
Registered
2014 C7 Z51 LT3 Convertible
Joined
·
12 Posts
I could write a book about my dealing with GM regarding the terrible shifting issue from 1-2 and 2-3. But I will spare you the boring but very frustrating details. According to a tech guy at Tremec I was experiencing a synchronization issue. My local GM dealer in Richmond made a 1.5 mm adjustment on the shift linkage below the console. This helped some. Finally I visited ZIP Corvette in Richmond, VA and they recommended Synchro Shift II 75W-90 viscosity. This made it much better even though the guy at Tremec told me not to do it. I now have 30 K miles on my C7 Z51 LT3 Convertible and some days it shifts nice and other days not. GM knows the have a problem, but they will never officially agree to it. I get this info from very good sources in Bowling Green
 

·
Registered
2014 Premier Edition
Joined
·
91 Posts
Discussion Starter #18
Not debating your shifting skills, but have you tried shifting at a higher RPM?
LOL - didn't take it personally. I tend to not "get on it" before the motor is warmed up but yes I did and yes it did do much better. Seems like it's at lower RPM levels 2-2.5Kish
 

·
Super Moderator
Joined
·
3,352 Posts
LOL - didn't take it personally. I tend to not "get on it" before the motor is warmed up but yes I did and yes it did do much better. Seems like it's at lower RPM levels 2-2.5Kish
Ok that's good. Thanks for trying it at a higher RPM. I noticed that grind early on with my 2015 and shifting at slightly higher RPM was the ticket.
 
  • Like
Reactions: jsvette and stevec

·
Registered
2014 Premier Edition
Joined
·
91 Posts
Discussion Starter #20
Ok that's good. Thanks for trying it at a higher RPM. I noticed that grind early on with my 2015 and shifting at slightly higher RPM was the ticket.
I read that earlier and given that it doesn't even have 4K on it yet I'm not too concerned. Still gonna have Pat drive it and discuss it with him. Thanks

And seriously, I don't take most any comment seriously. Unless of course it's an obvious attack and then the gloves come off...
 
1 - 20 of 37 Posts
Top