Stingray Corvette Forum banner

1 - 19 of 19 Posts

·
Registered
Joined
·
1,108 Posts
Discussion Starter · #1 ·
I get the red phone icon in the display. it says phone connected. I cant make it go away. When its present none of the DIC displays. I have tried phone off/ I have 3 paired and have tried each on or off--no difference. Any advice?? Charlie aka cutnout
 

·
Administrator
Joined
·
16,587 Posts
Are you talking about the main display? My phone and the number and the active or end related stuff shows up in the central screen but not the center screen where the tac etc is normally displayed. You may have set the configurable screen to the phone- try changing it.
 

·
Registered
Joined
·
1,108 Posts
Discussion Starter · #3 ·
Are you talking about the main display? My phone and the number and the active or end related stuff shows up in the central screen but not the center screen where the tac etc is normally displayed. You may have set the configurable screen to the phone- try changing it.
yes its the center display--shows phone connected--plus battery level. Whata do I punch to make it go away?? cutnout aka charlie
 

·
Moderator
Joined
·
1,406 Posts
I get the red phone icon in the display. it says phone connected. I cant make it go away. When its present none of the DIC displays. I have tried phone off/ I have 3 paired and have tried each on or off--no difference. Any advice?? Charlie aka cutnout
Is it the DIC or the infotainment screen?
 

·
Registered
Joined
·
1,166 Posts
yes its the center display--shows phone connected--plus battery level. Whata do I punch to make it go away?? cutnout aka charlie
Charlie
With your right thumb when holding the steering wheel push the left arrow key. This will open the center screen menu on the left side of the center screen. Now you should see the phone icon highlighted. Scroll up or down to change the center screen to info, perf,(performance) or what ever you choose.

That should fix it for you.

Let us know if that works.
 
  • Like
Reactions: cutnout

·
Administrator
Joined
·
16,587 Posts
As Tom suggested put the center display to "info" or "perf". If for example you put it in info, then this is an example of what you will see: P1060047.jpg

Then with it set to info, you can use the up or down arrows to change the information to show trip info including mpg, current speed (large digital), tire pressures, etc. You at some point must have set it to show your phone (you will see that is an option when you use the left arrows and see the choices in the list in addition to info, perf, etc.
 
  • Like
Reactions: cutnout

·
Registered
Joined
·
1,108 Posts
Discussion Starter · #7 ·
Charlie
With your right thumb when holding the steering wheel push the left arrow key. This will open the center screen menu on the left side of the center screen. Now you should see the phone icon highlighted. Scroll up or down to change the center screen to info, perf,(performance) or what ever you choose.

That should fix it for you.

Let us know if that works.
Perfect instructions and a perfect fix. Thank you so much. I have a BS degree with many electronic certs BUT there isn't any cathodes, grids, plates or filaments in this great car. The world is passing me by. Time to go back to school. cutnout aka Charlie
 

·
Registered
Joined
·
1,166 Posts
Perfect instructions and a perfect fix. Thank you so much. I have a BS degree with many electronic certs BUT there isn't any cathodes, grids, plates or filaments in this great car. The world is passing me by. Time to go back to school. cutnout aka Charlie
Glad it worked for you.
 

·
Registered
Joined
·
1,108 Posts
Discussion Starter · #9 ·
Glad it worked for you.
If someone owns a C7 then they had better get on this forum--good advice flows herein. Charlie aka cutnout
 

·
Registered
Joined
·
17 Posts
I can't seem to get my GPS to work properly. The GPS icon in the top right corner has a red X accross it. When attempting to use the GPS it's not showing my anywhere near where I'm actually driving, does anyone have any advice.
 

·
Administrator
Joined
·
16,587 Posts
That usually means that your car can not connect with the satellites. Hit your OnStar button and ask them to check it out and walk you through it. If that doesn't work you will need to take it to your dealer. Of course this all presumes you are not in your garage, under an overpass, etc.
 

·
Registered
Joined
·
1,108 Posts
Discussion Starter · #12 ·
I can't seem to get my GPS to work properly. The GPS icon in the top right corner has a red X accross it. When attempting to use the GPS it's not showing my anywhere near where I'm actually driving, does anyone have any advice.
Typically the antenna is not seeing the sky. Trees around? buildings? There has been a lot of discussion about the GPS but the only time I see the red X is when its blocked by something. cutnout aka Charlie
 

·
Registered
Joined
·
17 Posts
A few questions for the ones out here that are experienced with purchasing new Vettes. First is I'm getting the clear bra installed on the entire front of the car, full front nose , full hood and full fenders and the backsides of the Mirrors. I am wondering which product is the best for the paint to apply directly after taking delivery. I wouldn't let the deslership touch my car, I've heard of a few different products but I'm new to this do I need good quality advice.
Next question is regarding the break in period and the oil that is currently in the engine, am I suppose to wait until the first scheduled oil change at the recommended milage or am I suppose to have it changed at a lower milage?
Then wheels and tires are my next concern, I want an all black wheel and a quality tire for normal daily driving, does anyone have any good advise for me on a brand of wheel I can trust to be a good quality wheel and a tire to go on them that are what I need, shoud i buy run flats or not? I'm taking the stock wheels and tires and putting them up in the garage. Thanks for any help that you guys have. I'm trusting all the seasoned guys to help me out. Thank you
 

·
Registered
Joined
·
17 Posts
It's anywhere I attempt to use it, I did call onstar and had them give me a route and asked for assistance and still nothing worked. I went by the dealership and spoke to the owners son and he is researching it for me. Because it does it all of the time no matter where I'm at, at first when I attempted to use on star it wouldn't show any roads or POI's or anytning then out of nowhere it started showing roads but they are all incorrect .
 

·
Registered
Joined
·
17 Posts
Also one more question , does anyone have any info on the SMS texting app ? I can't seem to figure out how to utilize this feature. I do have an I phone so I'm not sure if there is a certain way I should be doing it or not.
 

·
Administrator
Joined
·
16,587 Posts
It's anywhere I attempt to use it, I did call onstar and had them give me a route and asked for assistance and still nothing worked. I went by the dealership and spoke to the owners son and he is researching it for me. Because it does it all of the time no matter where I'm at, at first when I attempted to use on star it wouldn't show any roads or POI's or anytning then out of nowhere it started showing roads but they are all incorrect .
You should call OnStar and have them run a diagnostic to see if they can tell if the GPS is not connecting. Without it connected to satellites mapping can not work. If your connection is intermittent, then it might be able to initially show where you are on a route/road but then would quickly become 'lost.' It is capable of showing your apparent location after it has had contact with a satellite and then lost it (for example when you travel through a long tunnel, your NAV screen will show your car progressing along the road until it re-establishes the satellite connection. I'm not sure why your dealer isn't running some tests to see if there is a problem with the connection to the antennae and then replacing appropriate components under the warranty. I suggest you PM ChevroletCustomerCare and ask for them to assist.
 

·
Registered
Joined
·
1,108 Posts
Discussion Starter · #17 ·
Glad it worked for you.
I think I discovered something with my phone/car today. If I have it paired and the battery on the phone goes down then "no phone detected" pops up with a red phone icon to the right of center. This could be a error message--maybe.
Then I would have to follow the path Tom described which worked. I don't know if this logic is sound--comments. I don't think I changed the display to phone but maybe I did--age is calling my name. cutnout aka Charlie
 

·
Registered
Joined
·
1,166 Posts
Charlie
I have 3 different iPhones paired to the car. My display always restarts where it was when I turned the car off.

Seems odd to me that you are getting back to the phone display if that is not where you were when the car was turned off. Maybe someone lease can comment.
 
  • Like
Reactions: cutnout

·
Registered
Joined
·
1,108 Posts
Discussion Starter · #19 ·
Charlie
I have 3 different iPhones paired to the car. My display always restarts where it was when I turned the car off.

Seems odd to me that you are getting back to the phone display if that is not where you were when the car was turned off. Maybe someone lease can comment.
I keep telling my wife that a gremlin is loose in the garage. For instance the tools are not put back where they belong. The gremlin puts dirt on the floor. AND just maybe the gremlin has hit the "phone" on the display just to fool me again. (weak attempt at humor) cutnout aka Charlie
 
  • Like
Reactions: Tom0021
1 - 19 of 19 Posts
Top