Stingray Corvette Forum banner

Belt tensioner failure / Cooling system leak poll

1 - 20 of 62 Posts

·
Registered
Joined
·
4,607 Posts
Discussion Starter · #1 · (Edited)
I am trying to determine just how many of our members have had issues in a couple of problem areas that seem to have a growing number of owners web-wide reporting them. This is a snap shot in time and is nothing more than that. Feel free to comment if you vote one way and find that you experience one of these items later. Also if you do post a reply please add your build date somewhere in your response and the mileage on your car when you experienced the problem. Please let us know if you have a repeat occurrence with either issue.
 

·
Administrator
Joined
·
16,595 Posts
Might want to modify the poll to have the response categorized as Z51 or non-Z51 since there seems to be a difference in the frequency of issues based on model option.
 

·
Registered
Joined
·
4,607 Posts
Discussion Starter · #3 ·
Might want to modify the poll to have the response categorized as Z51 or non-Z51 since there seems to be a difference in the frequency of issues based on model option.
I did not think there was any correlation for these issues, but it's a good idea to see if we can see one. Done!
 

·
Registered
Joined
·
16 Posts
Took my C7 to the dealership today to have a new radiator installed. Non z51 and took delivery in early April. 1964 miles on the car. I have had no other issues so far.


Sent from my iPad using Corvette Stingray Forum
 

·
Registered
Joined
·
57 Posts
Have my base model auto at dealership now having belt tensioner replaced..built in december right at 1000 miles when noise started
Thanks to forum I was able to not worry to much when researched prob and was able to mention to service rep also
 

·
Registered
Joined
·
699 Posts
Having the radiator replaced due to pin hole or crack that was dripping red oil. This is a Z51 auto. Vin #21885. Built 4/11/14. 5900 miles.

Michael
 

·
Registered
Joined
·
4,607 Posts
Discussion Starter · #7 ·
Having the radiator replaced due to pin hole or crack that was dripping red oil. This is a Z51 auto. Vin #21885. Built 4/11/14.

Michael
Michael; Don't forget to vote in the poll on the top of the page.
 

·
Administrator
Joined
·
16,595 Posts
Mike it appears from your Avatar that you have a Z51, correct?
 

·
Registered
Joined
·
582 Posts
My leak is actually coming from the radiator drain plug... I hope anyway will find out soon as I take it in.
 

·
Registered
Joined
·
429 Posts
Hydralic fluid leak but no discernible noise. Tensioner replaced. No reoccurence. Occured at ~6000 miles; VIN 4054; late Oct. build.
 

·
Administrator
Joined
·
16,595 Posts

·
Registered
Joined
·
57 Posts
What are the symptoms of belt tensioner failure besides a fluid leak. Do they make noise?
a lot of clatter from engine compartment,,thought it was car beside me first time I heard it,,happens between 25/40 mph when in 4cyl mode
 

·
Registered
Joined
·
63 Posts
Z 51 built on January 6. 2600 miles and belt tensioner was making noise. NDA part and gave me rental car for the night. No other problems with 3800 miles. I love this car!


Sent from my iPad using Corvette Stingray Forum
 
1 - 20 of 62 Posts
Top