Stingray Corvette Forum banner

1 - 14 of 14 Posts

·
Registered
Joined
·
20 Posts
Discussion Starter #1
While driving(on major roads with good cell phone reception) I keep getting messages that the device has disconnected and about 30 seconds later the message says that Bluetooth is connected. Have not lost any phone calls or had any dropped calls, but I may not have noticed whether the messages appeared while I am on the phone. I am using an IPhone 4S.

Are such disconnect/reconnect messages unusual and do they indicate something is wrong with my Bluetooth system?
 

·
Registered
Joined
·
10,424 Posts
The Bluetooth connection from your phone is independent from your phone's connection to a wireless tower. So, even if you were driving in an area where you could not get good phone service, your Bluetooth connection should still work without disconnecting/reconnecting.

What you are experiencing does not sound right to me.

If you can, experiment with connecting a different phone to your car. Also, do you ever connect your phone via Bluetooth to other devices, such as a headset? Does the intermittent connection follow the car, or your phone?
 

·
Premium Member
Joined
·
1,024 Posts
Re boot your phone.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #4
Phone works fine in 750 BMW and in AstonM DB9. No issues and no bluetooth disconnects. So problem seems to be C7 related.
Do not have a different phone to try at this time but may be able to use a friend's phone for a test.

Will try to reboot when the problem appears.

Thanks for your thoughts.
 

·
Registered
Joined
·
20 Posts
Discussion Starter #5
Rebooting phone did not work. In fact it stopped the car's Bluetooth system from connecting, but rebooting the car(turned off the car and restarted) did fix the problem--at least at this time. I will soon have an IPhone 6, so that may have no problems or maybe new challenges.
 

·
Registered
Joined
·
13 Posts
Hi All. I have a 2015 C7 and an Android Galaxy S5 phone. No problem pairing the phone. I have 2 problems however. While streaming music through the BT, the music cuts out often (no sounds at all) for about a second, then comes back, good for a few more minutes and it starts over again. During this time I noticed that when trying to advance to the next song on the car using the radio control, every thing lags by several seconds. In other words I can hit the advance button 2X several seconds will go by and then the songs will advance.

I have noticed if I unpair the phone and re-pair it again, everything works fine for a couple of days and then it starts all over again. Anyone else seeing any thing like this? I should also mention that I use this with two other cars BT and have no issues, only the C&
 

·
Registered
Joined
·
20 Posts
Discussion Starter #7
I switched to an Iphone 6 and so far have not had anymore bluetooth disconnect/reconnect issues.
 

·
Registered
Joined
·
38 Posts
Been having problems with the iPhone 6. When it connects to the car via bluetooth, it locks the voice control. I turn off bluetooth and all is fine. The phone doesn't work but can stream music and podcasts. I am having trouble with the phone in my audi also. I've tried just about everything with no solution. I read somewhere apple is coming out with an update- iOS 8.1 that will solve these issue. Supposedly coming out on the 20th. Will want until then.
 

·
Registered
Joined
·
305 Posts
got the same thing here about 2 or three times per minute but phone works all the time ive unpaired and paried my phone nothing changes
While driving(on major roads with good cell phone reception) I keep getting messages that the device has disconnected and about 30 seconds later the message says that Bluetooth is connected. Have not lost any phone calls or had any dropped calls, but I may not have noticed whether the messages appeared while I am on the phone. I am using an IPhone 4S.

Are such disconnect/reconnect messages unusual and do they indicate something is wrong with my Bluetooth system?
 

·
Registered
Joined
·
20 Posts
Instead of starting a new one decided to revive this. Was this issue ever fixed? Mine is doing the samething with the BT and its annoying when your trying to drive and listen to music. Thanks
 

·
Registered
Joined
·
20 Posts
Discussion Starter #12
2015TXvette--After I switched to an Iphone 6, I did not have anymore Bluetooth issues.
 

·
Super Moderator
Joined
·
3,362 Posts
I noticed if I plug my iPhone into the USB ports under the armrest, Bluetooth was not reliable. Using Spotify was a challenge because the Apple Music(iPod) would start playing and interrupt Spotify. Also, Google maps turn-by-turn over Bluetooth would only work if I played music from Apple Music(iPod). Apparently, those USB ports under the armrest give priority to Apple Music(iPod). So, now I use a USB adapter in the pop-up lighter and plug in a usb cable there. Everything works perfectly! I also have all my music on a usb stick plugged in behind the infotainment screen so I can get high quality sound directly from the infotainment system.
 
1 - 14 of 14 Posts
Top