Stingray Corvette Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
39 Posts
Discussion Starter · #1 ·
Since Christmas I've done two mods to my C7, I put side skirts and front splitter on, then this past weekend put a front camera on. Yesterday after everything was back together I went out for a test drive only to find my MIL lamp lit. I did do some drilling on to get the side skirts on properly, and disconnected the console electronics and pulled the trim and glove box out to route wiring.

I haven't been able to scan the car yet (read the code), but I'm wondering if anyone has any ideas about what could have caused the MIL indication (I know this is nearly an impossible question)? I'm hoping its just coincidence and that something didn't get broke when I was doing the mods. I didn't splice into any wiring either, I used the 12vdc and ground posts in the engine compartment for power. However I did have to remove the fuse box cover and lift the rear lever up over the fuse box to expose the 12vdc post.

Thoughts?
 

·
Registered
Joined
·
5,453 Posts
nothing hacked the car when you put in the camera?

My guess is the problem is somewhere here, in that it did not go back the same:

disconnected the console electronics and pulled the trim and glove box out to route wiring.
 

·
Registered
Joined
·
39 Posts
Discussion Starter · #3 ·
That would be my guess too. Hopefully when I scan it I will have an idea where the problem is.
 

·
Registered
Joined
·
5,109 Posts
Is your OnStar account still active? If so, they may be able to tell you what the code is. Could be completely unrelated to the mods you did.
 

·
Registered
Joined
·
39 Posts
Discussion Starter · #7 · (Edited)
Update, the code my scanner read was P159F. I cleared it and it didn't come back so I'm chalking it up to gremlins for now. (I actually think I know where the code came from, lets just say I did a dumb @$$ thing when I left the garage and leave it at that).

In reference to the above, I didn't tie it to the home screen display. Didn't even know there was an unused video input - how would you select that? Anyway, I was going to put a small monitor in the hidden cubby, but decided to put in in the console storage instead. It will be a little inconvenient, but I'm okay with that. I only put the camera in for the rare times I park nose first, and since the storage is so shallow, it isn't useful for much beyond a few papers.

Thanks to those who replied above.
 
1 - 7 of 7 Posts
Top