Stingray Corvette Forum banner

1 - 11 of 11 Posts

·
Registered
Joined
·
63 Posts
Discussion Starter #1
Just passed the 1500 mile mark and starting to hear a chatter/clatter metallic sound when letting out clutch in 1st and 2nd gear....doesnt happen when releasing clutch slowly, only when releasing medium....anyone else had this issue? are clutch issues covered under warranty?
 

·
Administrator
Joined
·
16,282 Posts
Take it to your dealer. It should be covered under the warranty at this stage.
 

·
Registered
Joined
·
77 Posts
I kind of have the same problem. It seems to only do it when it's not warmed up. Once warmed up and I've shifted through the gears a bit I have no problem. Is this not normal?


Sent from my iPhone using Corvette Stingray Forum
 

·
Registered
Joined
·
4,656 Posts
Normal is such a subjective term. Mine exhibits a bit of the aforementioned noise when cold as well as some chatter at slow speed such as parking lots, driveways and garages, especially when cold with the rpm's just off idle. So did my last 2 or 3 manual sports cars, especially the ones with dual mass flywheels. Whether it's normal or not can only be determined by someone with experience driving multiple manual C7's or a driveline engineer from GM. For my car this is normal. Is it normal for the C7, I have no idea but it's working exactly as it did when i picked it up at the factory with 3 miles on it and it was cleared by QC which leads me to believe it is normal.

CORRECTION - I just re-read the OP and I do not have any noise or chatter at speed, only at slow parking lot speeds and only when I'm being lazy on the throttle.
 

·
Registered
Joined
·
77 Posts
I don't remember hearing the noises when I first picked up my C7. But it could have been because we had it running for a while as we went over some of the interior stuff. Would like to get some other peoples opinion on if they hear some of the same noises when the vehicle is cold and driven at the lower speeds in first and second gear.
 

·
Registered
Joined
·
404 Posts
Maybe not the same issue... I sometimes get a little 'boink' when pushing in the clutch between gears... like I shifted before the engine hasn't had a chance to 'unload'... sound made by sudden unloading of universal joints I think.
 

·
Banned
Joined
·
631 Posts
If the pilot bearing has failed (or may have been missed during assy) the symptoms would be as you described, but also it the clutch got hot enough (hard launch, slippage, etc.) there will be be chatter as well to to the "divots" in the pressure plate and flywheel. Either way, bring it to the dealer...that is not normal.
 

·
Registered
Joined
·
755 Posts
Hi vegasbar10der:
If it is bothersome and doesn't sound normal, take it in and have them check it and let them tell you if it is normal or not. My issue is how do I put my ignition to accessary mode? I will probably find out before I get a reply but for now I am just being lazy and looking to you guys. haha!! Later .........STUNG
 

·
Registered
Joined
·
77 Posts
Well, sounds like I'll be taking it to the dealer to get this Checked out. Might have a hard time describing the sound though. Let's hope the microphone on the iPhone is sensitive enough (-:
 

·
Registered
Joined
·
4,607 Posts
Several issues come to mind, but rather than speculate on what it might be, have the dealer check it out. Please let us know what you find out. Good luck!
 

·
Registered
Joined
·
1,395 Posts
Hi vegasbar10der:
If it is bothersome and doesn't sound normal, take it in and have them check it and let them tell you if it is normal or not. My issue is how do I put my ignition to accessary mode? I will probably find out before I get a reply but for now I am just being lazy and looking to you guys. haha!! Later .........STUNG
To put the ignition in accessory mode on a manual transmission, just press the ignition button one time wIthout depressing the clutch. I have no idea on an automatic.


Sent from my iPad using Corvette Stingray Forum


Sent from my iPad using Corvette Stingray Forum
 
1 - 11 of 11 Posts
Top