Stingray Corvette Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
131 Posts
Discussion Starter #1
I have a 2014 Stingray and this started happening at the end of last summer. I just got it out this summer and it has been fine for a few weeks and then it just started again.
Anyone else have this issue? Any recommendations?


 

·
Registered
Joined
·
1,316 Posts
This was a common issue with the early 2014 builds. It will likely require a new head unit.


Sent from my iPad using Tapatalk
 

·
Registered
Joined
·
284 Posts
Do you have any more info? What should I tell the dealer they need to fix?
I had a similar issue with my 2016. Only, screen would blink like yours then go out. Eventually would just go out. My complaint on service ticket says "infotainment screen will not stay on and has only seconds of intermittent operation". The service ticket for mine says "Has internal HMI failure. Replaced and programmed HMI module"

Hope that helps.
 

·
Administrator
Joined
·
14,879 Posts
benplace, a number of 2014s (RedHot included- Here is my 2015 post "it did require the software updates last year for the info system to try and fix issues. which seemed to solve the problem for a couple of months. Then they recurred and they replaced the system. No issues since. There are several related TSBs for the info system. See your dealer and have them run your VIN to see which apply. I know that when my went, they were required to first try the software updates before they could get permission to pull the system for replacement. That seems to be the process according to others who have been through it as well. ") had similar issues early on. There are a few software updates that are required to be done before they will approve a replacement unit. Here are a number of related threads https://www.stingrayforums.com/forum/general-discussion/5328-infotainment-system-glitch.html https://www.stingrayforums.com/forum/general-discussion/37913-infotainment-screen-gremlins.html and https://www.stingrayforums.com/forum/tsb-recalls/14064-going-summary-tsbs-model-year.html#post184236
 

·
Registered
Joined
·
131 Posts
Discussion Starter #6
Thanks everyone, I am no longer under warranty so we will see what this is going to cost me...
 

·
Administrator
Joined
·
14,879 Posts
Thanks everyone, I am no longer under warranty so we will see what this is going to cost me...
Was it ever in the shop while under warranty for the software updates? If so, perhaps you might be able to get a good will out of warranty replacement.
 

·
Registered
Joined
·
20 Posts
@Benplace: VERY common on the 14’s! I would be surprised if any of them did not have this issue. Follow the links of the comments and do NOT take no for an answer from your dealer. It is a T SB and requires a replacement head and reflash. Chevy fixed it on the 25’s and later.
 

·
Registered
Joined
·
20 Posts
Check what other posters state. Don’t give up. Demand that the Zone Rep gets involved. I had same issue with my ‘14 out of warranty. Zone finally approved repair.
 

·
Registered
Joined
·
10 Posts
My 2014 lost the dash display, was re-flashed under warranty, then two weeks later the dash went black. I believe I had the first Stingray in the Denver area to have the dash totally replaced under warranty. My 2014 was a June 2014 build. My info display was not affected by the problems with the dash display. I took out an extended warranty since 2014 was the first year of the C7; it expires next year. I ordered my Stingray with the NCM delivery package, and have no problems with the exception of the dash issue.
 

·
Registered
Joined
·
131 Posts
Discussion Starter #12
Check what other posters state. Don’t give up. Demand that the Zone Rep gets involved. I had same issue with my ‘14 out of warranty. Zone finally approved repair.
If you have any other information on how you got it repaired out of warranty, that would be great.

My issue now is that it stopped doing it. I wonder if they will fix it with me only providing a video of it happening.
 

·
Registered
Joined
·
286 Posts
My C7 was built in December 2013 and I picked it up in January 2014. The first 2000 miles were fine and then the center display started to jump around. It was very intermittent. The display would be fine the next time I started the car. Then at some point it would jump around, go blank, try to reboot, and jump around some more. In hindsight, I should have had it fixed while the car was under warranty. I just had a new display installed last week. The charge for parts and labor was $970. My thought was I better get the display swapped out now before parts become scarce once the C8 comes out.
 
1 - 13 of 13 Posts
About this Discussion
12 Replies
7 Participants
abshapiro
Stingray Corvette Forum
We’re a forum community dedicated to the 7th Gen Corvette Stingray. Come join the discussion on performance modifications, accessories, purchasing, maintenance and more!
Full Forum Listing
Top