Stingray Corvette Forum banner

1 - 4 of 4 Posts

·
Registered
Joined
·
6 Posts
Discussion Starter #1
Z51 3LT, it seems as though the traction control button on the center console is stuck in the down position. ive only had the car about 3 weeks and I just tried the button the other day hoping to enter into the launch control feature, thats when i noticed that i was not able to press the button down (it seems to already be down and stuck in that position) there is no spring to the button at all. Anyone see this before and can someone tell me if theres a way to release the button? there are no lights lit up on the dash that say anything is on or off. thanks in advance guys!
 

·
Senior Member
Joined
·
18,669 Posts
Every Corvette I have had/have, when you press in the traction control button, you instantaneously receive a warning notice on the driver information center (now the IP screen).

Thinking that your button is broken in the non engaged position (meaning that you have not successfully removed your protective traction control system).

You may be very experienced in high horsepower cars, done a lot of racing, are highly skilled, am an accomplished driver many skills levels above me, but a caution, please, note to all reading this thread, I am aware of tens of serious to catastrophic incidents from folks disengaging their traction control to play with their Corvettes, folks who have no high horsepower or limited high horsepower skills/experience.
 

·
Registered
Joined
·
162 Posts
No worries here with skills! LOL

The traction control appears to be on when you first turn the car on. Read the manual. It says that it is always on when you turn the car on. It is when you mess with the button that you can then turn it off. I might be wrong but that's what I "think" I read recently. I can race with it or with out it. I was born that way! LOL :)
 

·
Registered
Joined
·
4,607 Posts
Z51 3LT, it seems as though the traction control button on the center console is stuck in the down position. ive only had the car about 3 weeks and I just tried the button the other day hoping to enter into the launch control feature, thats when i noticed that i was not able to press the button down (it seems to already be down and stuck in that position) there is no spring to the button at all. Anyone see this before and can someone tell me if theres a way to release the button? there are no lights lit up on the dash that say anything is on or off. thanks in advance guys!
Joey; So you think there is no movement on the button when you push it? If so, I suggest you check with a vette certified dealer and get it looked at.
 
1 - 4 of 4 Posts
Top