Stingray Corvette Forum banner

1 - 20 of 584 Posts

·
Registered
Joined
·
758 Posts
Discussion Starter #1 (Edited by Moderator)
At the request of several of you... This will get all of the issues together in one location and allow other owners and would be owners to learn about the issues that owners are experiencing or discovering.

What's allowed:

Factual accounts of issues you encounter as a real owner of a real car. Provide as much detail, pictures, and documentation as you are able to talk about the issue.

Factual accounts or updates regarding resolution of issues that you or your dealer provided to solve a problem with your Stingray. If you solve a problem and post a separate update, please edit your original post that it was resolved and reference the post with the update if possible.


What's not allowed (This will be strictly enforced):

Anecdotal comments about first year models.
Comments about other model year Corvettes (even if they may relate to current equipment.)
Stories or issues you read about on other forums.
Posting about a problem "your friend" had with their car.
Posting that "your car is fine" or "I didn't have that problem."


The intent of this thread is to collect data and provide information for people who own a 2014 Corvette Stingray. Hopefully we will see both problems and resolutions and allow a place for folks to learn how to deal with issues that they encounter. If you can provide content information (equipment group, options, etc.) about your car that would be welcome. If you can provide photos of the issue or video of the behavior, that would be welcome. If are willing to post your VIN number, that would be helpful so that others with VIN's in a nearby range can relate.

Let's see if we can keep this thread on topic and make it a useful place for new and would be owners to learn what is going on.
 

·
Registered
Joined
·
4,607 Posts
Folks we need to start using this thread to report what issues may be affecting our owners and what is being done to correct them. Please keep the guidelines above in mind when posting. This thread will give our Chevy Customer Folks a thread to keep an eye on, and not have to look all over the forum for items they can help you with.
 

·
Registered
Joined
·
2 Posts
Hello my name is Richard I own a 2014 Stingray.
I am new to this forum but, wanted to let everyone know about an issue my 2014 Stingray had and was repaired.
I picked up my Z51 automatic ...back in September, my car is one of the first 700 cars delivered.
Everything was fine for the first 480 miles but then, I started to notice a rattling noise when I was idling.
The noise was loud enough I could hear it with the top in and widows up.
I took the car in to my local dealer and after a few hours I was told although they could hear the noise...nothing was loose.
I was then told there just have not been enough Stingray deliveries to know if the problem was normal or not normal or if anything could be done to solve the issue..
I contacted Chevrolet customer assistance and explained my problem, Chevrolet was very interested and quickly move me up the channels.
I was contacted by the Service manager who let me know an engineer from the Corvette plant would be coming to Florida to listen to my car.
I asked the service manager if he could forward a short video to the engineer so he could listen to the problem before he arrived.
Below is a copy of my video.



Then I received another call from the service manager as a part had been sent from the plant .....would I come in?

when I arrived he walked me over to the garage to show me the part....to my surprise it was about 6 feet long and 2 feet around.
He told me the part was a Driveline support torque tube.
I am not technician so, to put in simple terms this part contains the driveshaft wrapped in a tube sorry I can not be more specific then that.
Feel free to do you own research.
I did not want to post anything until after the repair which is now done.... (two days) and many thousands in warranty repair costs but the noise is gone.....
at least for now. Since this issue did not happen right away I will have to wait and see.
I hope this helps someone who it hearing a rattling noise that was not there before ...you are not crazy GM may have an issue.
I would be glad to provide repairs orders,(as well as names of people with-in the service department that can be called) to the administrator of this site as proof this is a genuine issue.
Richard
 

·
Registered
Joined
·
476 Posts
Z51 7spd
Well a month ago I got a service rear end message pop up on the dash. I took it to the dealer & found out npt the low oil level problem but differential isn't locking.
They called GM & was told to replace the differential computer & the hydraulic pump. After that it worked fine for the last month but I just got the message again. I will be calling the dealer tomorrow & keep you guys informed.
 

·
Registered
Joined
·
21 Posts
I am also new to the forum and my name is Gerry
I was asked to re post this to get in the correct Thread.
Picked up my LT2 convertible C7 Dec 30. Drove it about a hour and lost voice control button on steering wheel blue tooth to my phone makes a loud clicking noise and drops my cell call... Navigation voice makes a loud clicking noise also when giving turn commands.. XM/FM radio stops working and seems to reboot about every 10 min. Random reboots to corvette screen. Sometimes the clock time changes back to 12:XX and then goes back to the correct time Dealer told me to remove all HD radio stations and try... turn off HD setting It made no changes ... They said Chevrolet says its a software problem.. And they are looking for a fix ... No resolution date provided... So my troubleshooting past tells me this could be a combo hardware software problem and they have been messing with it for the past 3 months... I will be on the phone Monday calling GM and expecting some one to give me something other than it's a software problem. I will try to update with anything I get back from Chevrolet.

01/08/14
Update I have been on the phone with GM support and they say that they are still working on the problem .. They did get back to me this morning and they have a software download that might improve my problems and I will take my C7 in tomorrow and they will download it for me.. I am not happy with the Chevrolet and how they are handling this. They say it is software and will not replace my nav system..
I say if it's software provide me with a fix.. or start troubleshooting the problem.. I still think that this could be a hardware issue and they don't care to come out with it now.. I say if you have a H/W problem
admit to it and get on with a fix.

I would like to suggest the the factory look into this problem in the diagnostic testing that they run after the car is built.. might be the RC but that's only a WAG on my part. BTW the battery reset corrected my problems after factory support requested Dealer do this.. they also updated with new software after 2 weeks. That's not to say that this is the total fix for the problem and root cause needs to be found but this is a Workaround. I will have to see how long it lasts but 505moters reports his power reset only corrected his problems since early November.
 

·
Registered
Joined
·
219 Posts
Does anyone know how the infotainment software update works? Does GM push update thru on star or we have to manually download updates and how do we know when they are available?

Sent from my SGH-M919 using Corvette Stingray Forum mobile app
 

·
Registered
Joined
·
579 Posts
Does anyone know how the infotainment software update works? Does GM push update thru on star or we have to manually download updates and how do we know when they are available?

Sent from my SGH-M919 using Corvette Stingray Forum mobile app
Call your dealer...
 

·
Registered
Joined
·
4,607 Posts
At this point it is dealer only. I have read where a dealers service dept. told an owner that it may take up to two hours to do. I wish I understood why it would take this long to accomplish?

edit: It seems that the 2 hr. figure was because the dealer had issues with the download. It appears it should only take a 1/2 hour or so depending on the individual who is doing the re-flash.
 

·
Registered
Joined
·
1 Posts
Jan 7. New to the site and first post. I have about 2000 miles on my C7 and a few problems.
1- Oil leak at the reverse light switch on manual tranny. Switch replaced.
2- Right steering wheel control inoperative intermittently and no blue tooth connection: Bulletin #PIC5948. I am told software is being created but not yet available. The bulletin didn't say anything about the following, my emergency brake also released when I started the car during this problem. So it may be connected? Everything is working correctly at present, but keep it in gear when parked.
3- Instrument panel brightness too low. Chevy has a fix for this, but I haven’t gone back yet for the software update.
Bob
 

·
Registered
Joined
·
424 Posts
At this point it is dealer only. I have read where a dealers service dept. told an owner that it may take up to two hours to do. I wish I understood why it would take this long to accomplish?

edit: It seems that the 2 hr. figure was because the dealer had issues with the download. It appears it should only take a 1/2 hour or so depending on the individual who is doing the re-flash.
I took Scarlet in for an update a couple of weeks ago. Not sure if she needed a refresh or not. The process did take a while and I was told that the update must be initiated and completed serially, module by module. My originally delivered software (VIN in low 4000s) must have been ok since I didn't see any changes following the update. The software (or processor or both) remains rather slow...changing radio stations, media sources, driving mode changes, etc. Not a big deal, I guess.
 

·
Registered
Joined
·
21 Posts
Two questions....are there Technical Service Bulletins or recalls on the C7's? Do dealers normally contact owners if there is a Technical Service Bulleting, such as the low differential fluid issue? Thanks,
 

·
Registered
Joined
·
4,607 Posts
No recalls yet. Some owners are reporting that their dealers contacted them about TSB's, but many find out about them on forums such as ours first. We try to establish the correct TSB numbers and if owners contact their dealers service dept. they specifically ask about a given TSB. Your VIN will enable your service rep. to check to see if your car is included in any TSB's.
http://www.stingrayforums.com/forum/stingray-corvette-news/1877-service-bulletin-13384-low-differential-fluid-level.html
 

·
Registered
Joined
·
209 Posts
Has anyone had any issues with the back up camera getting blurry? Mine seems to blur anytime I back up into my driveway and/or garage. My husband thinks it may have an autofocus that is getting fixed on the pavement lines or something. If we stop and let it sit there for a minute the picture will clear up but as soon as we start moving again, it blurs.
20140110_10.jpg 20140110_11.jpg
 

·
Registered
Joined
·
424 Posts
I can't imagine an autofocus feature being part of the camera since it's always pointed at the same angle and fixed point. I'm wondering if the backup lights may be "blinding" to camera, especially if your driveway/garage floor are coated with a light color and/or reflective surface. I know that may be reaching. My driveway is surfaced in very light blue. I will attempt to replicate your problem tonight. BTW, this only happens in your driveway/garage?
 
1 - 20 of 584 Posts
Top