Stingray Corvette Forum banner

1 - 8 of 8 Posts

·
Registered
Joined
·
91 Posts
Discussion Starter #1
Looking for some expert advice. My 2015 Night Race Blue Metallic was coated with CQ Finest a month after I got the car in 2015. I’ve been diligent is keeping it clean, but also drive it as frequently as I can. Over the last few months, I noticed what looks like white splotches under the garage lights show up on the hood and front fenders. I do not see these on either door, roof, or rear deck. They are difficult to see with a camera, but I have included a few after I washed it yesterday. Any opinions on these before I take it to a detail shop? They are basically invisible in sunlight. I cannot feel them - the paint is smooth. Thanks in advance for your thoughts.
 

Attachments

·
Administrator
Joined
·
15,693 Posts
Unusual. No idea. I had RedHot CQ Finest shortly after I drove her home from NCM. The treatment is going on 7 years and I don't see anything similar to what you are finding on your NRB. Hopefully your detailer can figure it out and resolve.
 
  • Like
Reactions: TXAg92

·
Registered
Joined
·
1,600 Posts
Hmmm if its under the clearcoat then perhaps its a paint defect. Almost looks like the metallic flake is oxidizing or reacting to some other environmental issue. If this is the case i would be suprised if the detailer could do anything for you. However good luck and please report back.
 

·
Registered
Joined
·
91 Posts
Discussion Starter #4
Hi everyone. Finally got it to the detail shop today. Believes is a topical issue, and will bring it back next week for a full polish. Thinks it came from the rinseless product I have used for awhile. Build up over time. So, hoping to post some awesome pictures after I take it in next week! Thanks for the comments.
 

·
Administrator
Joined
·
15,693 Posts
Hi everyone. Finally got it to the detail shop today. Believes is a topical issue, and will bring it back next week for a full polish. Thinks it came from the rinseless product I have used for awhile. Build up over time. So, hoping to post some awesome pictures after I take it in next week! Thanks for the comments.
Interesting. Glad it sounds to be more on the surface rather than beneath the clear coat. What rinseless product have you been using?
 

·
Registered
Joined
·
91 Posts
Discussion Starter #6
I have been using Wolfgang. The detailer is going to recommend another couple of products to try. I followed Glen’s documents from way back. It worked....until it didn’t Jeff!
 

·
Administrator
Joined
·
15,693 Posts
I have been using Wolfgang. The detailer is going to recommend another couple of products to try. I followed Glen’s documents from way back. It worked....until it didn’t Jeff!
I have only done true washless a few times on RedHot. Wolfgang does have a good rep. However, I can see the possibility of a buildup when using washless without any rinse.
 

·
Registered
Joined
·
22 Posts
I used a 50/50 mix of distilled water and white vinegar for quick cleaning on my C-5 and use it on my C-7 now. Seems to clean well, leaves no spots and doesn't remove any polish. I've never even heard of rinseless wash until now.
 
1 - 8 of 8 Posts
Top