Stingray Corvette Forum banner

Status
Not open for further replies.
1 - 14 of 14 Posts

·
Registered
Joined
·
9 Posts
Discussion Starter · #1 ·
New to the forum and have a new 2015 LT3 Corvette. I have a question on something I have noticed on the media playback.

It seems when I advance to the next song, the next song starts up just fine. But then just after it starts, I experience a brief interruption in playback. I have figured out this happens when the album art is loading on the display. So, something funky is happening while the graphic is loading that’s effecting the music playback. This happens on Bluetooth, USB and SD media. It’s less noticeable on SD but it still happens. Anyone else run across this?
 

·
Registered
Joined
·
10,543 Posts
So this only occurs when you "surprise" the system by telling it to "start the next song now" instead of letting the presently-playing song finish? If that is the case, others may have the issue as well, but have just not noticed it because they let the present song finish.

If that is the case, it sounds like the computer controlling this may be under-powered for the task in general, but it usually is not noticed because there is a work-around in the algorithm to preload the next album art at a certain time. But your "surprise - switch and load it now" exposes what is otherwise never noticed in normal use.

Maybe others can experiment and confirm or refute this.

By the way, welcome to the forum!
 

·
Registered
Joined
·
3,718 Posts
It seems when I advance to the next song, the next song starts up just fine. But then just after it starts, I experience a brief interruption in playback.
I advance to the next song while a current one is playing all the time and have never experienced what you describe. I use an Ipod Nano.
 

·
Registered
Joined
·
10,543 Posts
Well, Boomer gave strike one for my theory. Now if someone can confirm seamless play with displayed album art during surprise advance to the next song for Bluetooth, USB, or SD media, then my theory will be dead.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #6 · (Edited)
The interruption will happen if you let the song advance on its own, sometimes.

I'm almost 100% it's related to album cover graphics now because is tested a album with no cover tagged and no problems. I can advance to the next song every time without a hickup. I'm going to play around with the MP3 tagging and see if I can narrow it down.

I will try my iPhone direct connected to see what happens, I haven't tried that yet. So far it's Bluetooth, USB and SD media for sure. The slower the media the longer the interruption. So when using Bluetooth it more noticeable than when using SD.
 

·
Administrator
Joined
·
16,494 Posts
Welcome to our forum Bytor! Congrats on your C7.:eek:nthego:
 

·
Registered
Joined
·
504 Posts
If due to album art, perhaps reducing the size/file size of the image on your media will allow for it to load quicker without the hiccup.
 

·
Registered
Joined
·
3,672 Posts
  • Like
Reactions: Boomer

·
Registered
Joined
·
9 Posts
Discussion Starter · #10 ·
A quick update. It doesn't seem to be a problem with the album images after all. I played around with image sizes and removing images and found I still had the issue on about 1/3 of the MP3's in my test collection. A smaller image size does load quicker though. On about 1/3 of the songs in my collection, I get the interruption exactly at the 1sec count on the track time counter. The same problematic tracks play fine on my wife's GMC Acadia system, home MP3 jukebox and iPhone and I can skip songs with no interruption in playback when the next song starts. These MP3's were ripped years ago so there could be some corruption or something that the vette system is sensitive to. Thanks for the tips Mobius, I'm going to do some re-ripping and testing to see if I can narrow down the issue.

On a related note, is there a list of infotainment software update release notes available? Might be interesting to see if this is a symptom of a bug or something.
 

·
Registered
Joined
·
9 Posts
Discussion Starter · #11 · (Edited)
Here's the HMI system software I'm currently running. GMG2_14.1F013


IMG_3185.JPG




Here's the only reference I could find related to a version list. Found this on the Bosch site. I would love to find a release notes list to see what bugs are corrected in the various versions. It seems there is atleast one new version for the 2015 system. (SW 14.0F105)

Bosch Open Source Software

To verify the HMI build version on a C7, press the Power, Menu and Home buttons at the same time on the infotainment system, and then select HMI from the onboard development screen.

How to check current version

Does anyone on the forum know what the recent versions are or know of any specific bug fix info related to the infotainment system?



Here's some good info on the HMI NG1.1 module. This particular module is for the Cadillac and Cadillac User Experience (CUE)
The C7's run the HMI NG2.0 module but the architecture is similar I would imagine.
Very good info, sheds some light on the interworkings of the HMI.
Bosch NG1.1 HMI Teardown | IHS Electronics360

Bosch_NG1_1_HMI_(iSi)_-_Main_PCB_Bottom.jpg Bosch_NG1_1_HMI_(iSi)_-_Main_PCB_Top.jpg
 

·
Registered
Joined
·
3,672 Posts
It's good to see that the software is open source and available.

A quick Google search identified this mobile page, which discusses MyLink updates. It mentions a login, but I don't see any login field on the mobile site... hope it provides additional clues.
Capture.JPG
 

·
Registered
Joined
·
16 Posts
I tried to go to your link for checking the version and it is a malware link. My computer freaked out for about 2 min before I could stop it. Your blog spot must have a virus or malware on it.
 

·
Administrator
Joined
·
16,494 Posts
I tried to go to your link for checking the version and it is a malware link. My computer freaked out for about 2 min before I could stop it. Your blog spot must have a virus or malware on it.
This thread is from 2015 with no updates prior to your post. So that others will not have the same issue of a potential virus, the thread will be closed.
 
  • Like
Reactions: ckrouse
1 - 14 of 14 Posts
Status
Not open for further replies.
Top