Stingray Corvette Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
739 Posts
Discussion Starter #1
Decided to see what track mode is like. Essentially have always driven in sport mode. Today went for a spin in track. Soon noted noise when shifting. A thud when shifting gears. Even my wife noticed it and asked me what I was doing. Also a soft but definite high pitched whine from the rear end. Then the LCD. Screen started to flicker. Very distracting. Switched back to sport and it all went away. Anyone have ideas? Will try it again tomorrow to see if it was just some gremlin!
 

·
Administrator
Joined
·
16,313 Posts
From your signature it appears that you have a non-Z51 so when you shift your drive Mode from Sport to Track there are few differences (steering will feel tighter and require more effort, exhaust mode will be more aggressive sounding) and nothing that should result in a "thud" when shifting gears. Were you driving more aggressively to test out "Track" Mode and possibly not letting out the clutch the same as you normally do? Remote chance that could contribute to the thud. But it should not have a high pitched whine from the rear end and the LCD issues are independent of Mode and both should be brought to your dealers attention. Please let us know what your dealer says and does.
 

·
Registered
Joined
·
3,667 Posts
I have a base 7-speed, and always use Track Mode around town (around 2500 miles in Track so far), as I prefer the higher responsiveness and exhaust note.

I've never encountered what you are describing, and I'm not sure what could be causing it.

Please keep us up to date as you get it resolved.
 

·
Registered
Joined
·
739 Posts
Discussion Starter #4
I will try to reproduce it tomorrow and update issue.
 
  • Like
Reactions: Mobius

·
Registered
Joined
·
810 Posts
Yikes, don't like sound of that. Finally used track mode on Kentucky Speedway on my z51, none of what you experienced.
 

·
Registered
Joined
·
7,930 Posts
Petercwelch, I hope that you get every thing squared away.

SF
Rick
 

·
Registered
Joined
·
739 Posts
Discussion Starter #7
Decided it was the clutch rather than the shift. To dealer. Listened to it on drive and compared to two c7s. They believe all have the same sound, and they may. They are replacing the radio due to the previously described flipping on the screen. I hope they are right. I am currently satisfied. We will eventually see I am sure. Best to all.
 
  • Like
Reactions: Mobius

·
Registered
Joined
·
504 Posts
I have driven numerous Z-51 seven speeds in track mode at Spring Mountain Raceway and none of them made any noises as you described. My Z51 has never made any of those noises as well. Not normal!
 

·
Administrator
Joined
·
16,313 Posts
Like Ken stated, we drove a bunch of different Z-51 7 speeds at Ron Fellows in Track mode and never experienced the thud sound or other noise you described from yours. If your dealer is saying that is normal, encourage you to take it to another dealer if possible for review.
 

·
Registered
Joined
·
739 Posts
Discussion Starter #10
Thank you both for your input. Some problems installing the new radio but will give them a little more time. I am now second guessing myself about the shift/clutch noise. Maybe I am exaggerating normal sounds. Time will certainly tell. Once new radio is in will leave on a weeks vacation to Maine. I will pay close attention. Again, appreciate your input!
 
1 - 10 of 10 Posts
Top