Stingray Corvette Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
214 Posts
Discussion Starter · #1 ·
Haven't been through the manual yet to see if there is a solution or if I'm doing something wrong but yesterday.... while idling in the driveway in neutral with the ebrake on I gave the pedal a shot so I could hear the exhaust babble and to my surprise the ebrake disengaged. Tried it several times to make sure I wasn't dreaming with the same result.

I tried it again today and it staedy engaged (as I believe it should). Not sure if there was a thread on here that answered this before but looking for a possible answer.
 

·
Registered
Joined
·
7 Posts
Weird..obviously it will auto disengage when you try to move foward or backward ..but in netural..haven't had that happen
 

·
Registered
Joined
·
98 Posts
A6 or M7 car?
S.
 

·
Administrator
Joined
·
16,583 Posts
Weird..obviously it will auto disengage when you try to move foward or backward ..but in netural..haven't had that happen
No I do not believe that is correct. If you have the ebrake on it should not auto disengage no matter what. RedHot's has never done that, nor has the similar one on my XTS.
 

·
Registered
Joined
·
4,607 Posts
Haven't been through the manual yet to see if there is a solution or if I'm doing something wrong but yesterday.... while idling in the driveway in neutral with the ebrake on I gave the pedal a shot so I could hear the exhaust babble and to my surprise the ebrake disengaged. Tried it several times to make sure I wasn't dreaming with the same result.

I tried it again today and it staedy engaged (as I believe it should). Not sure if there was a thread on here that answered this before but looking for a possible answer.
I don't think we have had anyone comment on an issue like this. The only thing even close is that some owners have commented how easy it is to engage the e-brake unintentionally. Keep us posted on what you find out.
 

·
Registered
Joined
·
429 Posts
Haven't been through the manual yet to see if there is a solution or if I'm doing something wrong but yesterday.... while idling in the driveway in neutral with the ebrake on I gave the pedal a shot so I could hear the exhaust babble and to my surprise the ebrake disengaged. Tried it several times to make sure I wasn't dreaming with the same result.

I tried it again today and it staedy engaged (as I believe it should). Not sure if there was a thread on here that answered this before but looking for a possible answer.
My car was held in BG for about a month. On another forum, I heard that about 50 cars were held pending replacement of an e-brake assembly at the same time my car was held. It may be just a coincidence that my car was held at the same time. Come to think of it, since I never use an e-brake, I haven't even tried it. Duh. At any rate, if the issue persists, ask your service mgr. to test it and do a little research. If service confirms the issue, they may have missed it in BG QC.
 

·
Registered
Joined
·
21 Posts
I love my E Brake.
 

·
Registered
Joined
·
98 Posts
No I do not believe that is correct. If you have the ebrake on it should not auto disengage no matter what. RedHot's has never done that, nor has the similar one on my XTS.
This is incorrect. The EPB will automatically release when the car is placed in gear and the throttle is applied. There is even a section in the Owner's Manual about "Automatic EPB Release".
S.
 

Attachments

·
Administrator
Joined
·
16,583 Posts
This is incorrect. The EPB will automatically release when the car is placed in gear and the throttle is applied. There is even a section in the Owner's Manual about "Automatic EPB Release".
S.
Thanks for correcting me Snorman, I did not know that and missed it in the manual. The once or twice I have put it into gear with the EPB on and started slowly it did not release and the car did not move. But again, it was with very slight throttle.
 

·
Registered
Joined
·
98 Posts
Thanks for correcting me Snorman, I did not know that and missed it in the manual. The once or twice I have put it into gear with the EPB on and started slowly it did not release and the car did not move. But again, it was with very slight throttle.
It may be something for the dealer to check against other cars. Mine releases with just a hint of throttle.
S.
 
1 - 10 of 10 Posts
Top