Stingray Corvette Forum banner

1 - 12 of 12 Posts

·
Registered
Joined
·
49 Posts
Discussion Starter · #1 ·
I was painting some engine part this weekend I did the following
1. cleaned the parts with dawn
2. sprayed primer/ adhesive
3. sprayed base coat

this is when it got weird sprayed clean coat everything was looking good came back in 10 minutes and I have little pit marks all through the clear does anyone have any thoughts on what went wrong PLEASE HELP
 

·
Administrator
Joined
·
16,510 Posts
Perhaps the humidity was high and the base coat had not thoroughly dried before you sprayed a clear coat?
 

·
Registered
Joined
·
623 Posts
Pictures?
 

·
Registered
Joined
·
80 Posts
pictures will definitely help, but does it now look wrinkled?

If it does, that means you didn't follow the coating times you needed for the paint you used. Rattle cans will tell you on the label, layering needs to happen within x amount of time or after y amount of time, if you do it wrong, it will wrinkle up.
 

·
Registered
Joined
·
706 Posts
It’s either solvent popping, or fish eyes.

First is not enough flash time between spraying the base and the clear.
Second is some sort of contamination.

jst guessing by I’d say it’s contaminated. Dawn is no substitute for actual cleaning solvents like Autoprep..
 

·
Administrator
Joined
·
16,510 Posts
Based on the images, still feel that not enough time was allowed between coats for thorough drying. Higher humidity requires additional time.
 

·
Registered
Joined
·
80 Posts
I would agree with Jeff, it looks like it might be the paint underneath gassing out which causes tiny bubbles to come up and make little tiny holes in the paint.
 

·
Registered
Joined
·
186 Posts
it appears to be solvent pop.Clear started to dry before the solvent could be released. happens a lot in hot weather even in our spray booths
 
1 - 12 of 12 Posts
Top