Stingray Corvette Forum banner

1 - 7 of 7 Posts

·
Registered
Joined
·
35 Posts
Discussion Starter · #1 ·
So today I take the vette to the dealer. Ac/heater controls not working. Thinking it was just a programming issue I prepared for a minor set back and sat back with hopes of cruising within a couple hours. 7 hours later the dash is completely disassembled, seats are out and it looks bad. Spoke to the service/head of electrical and they cannot find the problem. The more they get into it the more codes that appear. Dealer thinks at this point the complete wiring harness might need to be changed.

This totally sucks.
 

·
Registered
Joined
·
475 Posts
Sounds like the dealer does not know what they are doing. When you start pulling the wires out the car will throw codes.......


Sent from my iPad using Corvette Stingray Forum
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #3 ·
There just wiggling the wiring harness to try to find what they said was a ground in the hvac. The more they wiggle it the ground shows up on other systems. This they think the harness has a major problem.



Sent from my iPhone using Corvette Stingray Forum
 

·
Premium Member
Joined
·
4,194 Posts
So today I take the vette to the dealer. Ac/heater controls not working. Thinking it was just a programming issue I prepared for a minor set back and sat back with hopes of cruising within a couple hours. 7 hours later the dash is completely disassembled, seats are out and it looks bad. Spoke to the service/head of electrical and they cannot find the problem. The more they get into it the more codes that appear. Dealer thinks at this point the complete wiring harness might need to be changed.

This totally sucks.
wade1974,

Sorry to hear about your wiring harness concerns. I realize how concerning that would be. Keep us posted on the results of your dealer visit. If necessary, I can contact their designated Customer Experience Manager if you have any additional questions. We'll look forward to your updates :).

William R.
Chevrolet Customer Care
 

·
Registered
Joined
·
4,607 Posts
This totally sucks.
Wade; Your right it does! Allow me to ask a few questions; What is your car's date of manufacture? How many miles are on it now, and at what mileage did your problems start. Were there any other systems involved besides your AC? Is this gong to be a complete harness replacement? Speaking only for me, I sure don't like the sounds of this.
 

·
Registered
Joined
·
35 Posts
Discussion Starter · #6 ·
Hey guys,
I apologize for taking so long to respond. Well after a couple days it turned out to be loose wires in one of the plugs. When they wiggled them they would contact others and caused all the various codes.
I am very happy to say that after they fixed the loose wires the problem is fixed.
Great job gm for the repair.

Only negative side is the gouge left in one of the side plastic pieces from removing the passenger seat.

Anyway thanks guys.




Sent from my iPhone using Corvette Stingray Forum
 

·
Registered
Joined
·
4,607 Posts
Wade; Good to hear they got you fixed up. Do you know if there was an existing TSB or PIP found by your dealer in order for them to sort it out?
 
1 - 7 of 7 Posts
Top